Aggiornare Ubuntu 15.04 Vivid Vervet a Ubuntu 15.10 Wily Werewolf da terminale

Da ieri è disponibile l’aggiornamento in oggetto, per eseguire l’avanzamento di versione da terminale e godere, tra le altre novità, del nuovissimo kernel 4.x, basta un:

sudo su

Inserire la vostra password utente e poi:

do-release-upgrade

Infine, seguire le semplici istruzioni a schermo.

Attenzione che la mappazza da scaricare è notevole, nel mio caso è di poco meno di 600GB.

Prima di fare tutto ciò ovviamente avrete fatto una copia completa dei vostri dati onde evitare improbabili -ma NON impossibili!- spiacevoli conseguenze 🙂

Annunci

  1. Monica

    Ho fatto l’aggiornamento da vivid vervet e ora il PC si blocca su uno schermo nero xon tutti ok in verde e sctitte bianche ma non procede e non funziona neanche più la tastiera. Aiuto.

    • gnulinuxarea

      Ciao mi dispiace tu abbia avuto problemi, alla fine del post consiglio chiaramente di fare un backup dei dati importanti prima dell’aggiornamento in quanto è possibile che qualcosa vada storto, la cosa migliore da fare secondo me è salvare i dati con un livecd se non l’avevi già fatto e poi installare direttamente la 15.10 da zero. Personalmente ho eseguito l’avanzamento su due pc desktop e un portatile e tutto è andato a buon fine, mi spiace davvero per te.

  2. carla

    Ho riattivato ora un pc che non usavo da tempo, mi si propone lupgrade e sul terminale appare:
    carla@carla-HP-655-Notebook-PC:~$ do-release-upgrade
    Verifica un nuovo rilascio di ubuntu
    Il rilascio di Ubuntu in uso non è più supportato.
    ERROR:root:incorrect translation for message ‘For upgrade information, please visit:
    %(url)s
    ‘ to ‘Per informazioni sull’avanzamento consultare:
    $(url)s
    ‘ (wrong number of arguments)
    For upgrade information, please visit:
    http://www.ubuntu.com/releaseendoflife

    Scaricamento di:1 Firma dello strumento di avanzamento versione [836 B]
    Scaricamento di:2 Strumento di avanzamento versione [1.265 kB]
    Recuperati 1.266 kB in 0s (0 B/s)
    autenticazione di «xenial.tar.gz» con «xenial.tar.gz.gpg»
    estrazione di «xenial.tar.gz»
    [sudo] password for carla:

    Lettura della cache

    Controllo gestore dei pacchetti

    Impossibile eseguire l’avanzamento

    An upgrade from ‘vivid’ to ‘xenial’ is not supported with this tool.

    carla@carla-HP-655-Notebook-PC:~$
    che faccio?
    Grazie

    • gnulinuxarea

      Hola 🙂
      Credo che l’opzione più semplice sia salvare tutto il contenuto dell’hard disk che contiene l’installazione attuale altrove (vedi tu se hai configurazioni particolari e vuoi salvare qualche file conf) e poi un bel install da zero dell’ultima versione. Prima di tutto ciò magari prova la versione che vorresti installare via livecd per verificare che il tuo hardware sia supportato 🙂

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...